Your Digital Media Has Never Looked So Good

 
diamondlod

Roku 1000 not detecting Windows 2003 server shares

Thu Oct 07, 2004 10:33 pm

The Roku HD1000 does not appear to be able to detect shares on a Windows 2003 server. On a default build with the server set up with the role of a file server and with multiple shares created open to the Everyone group in both sharing and ACL security, the Roku doesn't even display the server as an option in the selection window. (And yes, they're on the same network, etc. In fact, the server is where the HD1000 got its DHCP address from!)

So how do we get this to work before my 30 days from purchase runs out and I have to return it?

Thanks
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Fri Oct 08, 2004 7:27 am

I had the same problem with a few of my computers.

Turns out the problem was with the default security configuration on Windows 2003. To get it to work, I had to disable SMB packet and secure channel signing, by doing the following (per http://www.digitalissues.co.uk/html/os/ms/smb2000.html):

http://www.digitalissues.co.uk/html/os/ms/smb2000.html wrote:
To disable SMB packet and secure channel signing enforcement on Windows Server 2003–based domain controllers

1. From Administrative Tools open Domain Controller Security Policy
2. Smile
3. Select \Security Settings\Local Policies\Security Options folder.
4. In the details pane, double-click Microsoft network server: Digitally sign communications (always), and then click Disabled to prevent SMB packet signing
from being required.
5. Click OK.
5a. In the details pane, double-click Microsoft Network Server: Digitally Sign Communicates (If Client Agrees) and then click to "Disabled".
6. In the details pane, double-click Domain member: Digitally encrypt or sign secure channel data (always), and then click Disabled to prevent secure channel
signing from being required.
7. Click OK.

To apply the Group Policy change immediately, either restart the domain controller, or type gpupdate at a command line, and then press ENTER.

If you change these setting and still have a problem, try checking in the following area.

1. Open Active Directory Users and Computers, right click the Domain Controllers container and click Properties
2. Click the group policy tab and then on edit
3. Under Computer Configuration, go to the Windows Settings\Security Settings\Local Policies\Security Options folder.
4. In the details pane, double-click Microsoft network server: Digitally sign communications (always), and then click Disabled to prevent SMB packet signing
from being required.
5. Click OK.
6. In the details pane, double-click Domain member: Digitally encrypt or sign secure channel data (always), and then click Disabled to prevent secure channel
signing from being required.
7. Click OK.

To apply the Group Policy change immediately, either restart the domain controller, or type gpupdate at a command line, and then press ENTER.

I hope this helps!

TheEndless

[edit]added 5a for 2.0+ beta compatability[/edit]
Last edited by TheEndless on Sun Jun 12, 2005 8:50 am, edited 2 times in total.
 
diamondlod

Success

Fri Oct 08, 2004 3:46 pm

I can't believe I didn't think of that one. I'm supposed to be the guy who catches all that stuff.

That definitely did it. Changing those two settings and refreshing worked immediately. No reboot was necessary, and now it works perfectly.

Thanks for your help. Now I can enjoy my Roku, and they can now state that Win2k3 works with the HD1000!
 
User avatar
TheEndless
** Valued Community Member **
Posts: 9231
Joined: Mon Oct 04, 2004 10:15 am
Location: US
Contact:

Fri Oct 08, 2004 8:40 pm

Excellent! I'm glad it worked for you. I remember tearing my hair out for several days configuring and re-configuring my network, before I found that answer.

Enjoy!

TheEndless
 
rcolbert
Posts: 22
Joined: Sat Jan 08, 2005 11:29 am

Sat Jan 08, 2005 12:09 pm

Bump

This should be a sticky until there's official AD support....
 
john_lawson
Posts: 3
Joined: Thu Feb 17, 2005 4:24 pm

May also need "IF CLIENT AGREES"

Thu Feb 17, 2005 4:30 pm

It would seem that, after upgrading to Beta2, it is necessary to change one more setting:

Microsoft Network Server: Digitally Sign Communicates (If Client Agrees)

I changed mine to "Disabled".

I am running Windows Server 2003. I was able to mount my shares succesfully on the HD1000 in all versions prior to Beta1, and even Beta3 failed to be able to mount any of my Windows Server 2003 shares (shile it did just fine on Windows XP Pro on a different box.

When I backed the HD1000 version back to 1.5.18, I was able to mount the WS2K3 shares just fine. WHen I re-installed Beta3 on the HD1000, the shares would not mount (I could see them, however), and I could inspect them using smbclient (from a telnet session).

When I changed this policy setting (and ran gpupdate), I am now able to mount the shares from the HD1000.

Who is online

Users browsing this forum: No registered users and 1 guest