Your Digital Media Has Never Looked So Good

 
jeffw
Topic Author
Posts: 14
Joined: Fri Feb 24, 2006 11:08 pm

Unable to update to version 2.x.x software

Fri Feb 24, 2006 11:58 pm

I've scoured this forum for help, but I'm not having any luck finding an answer. I purchased a rev b hd1000 (serial # HD1000K4A000706) with software version 1.5.18 installed. I am trying to install the 2.0 beta version of the software with the download and instructions on the following web page:

http://www.rokulabs.com/support/HD10002.0Beta.php

I have two CF cards. One is a SanDisk 1.0GB, the other is a Viking 256MB. Here is my problem:

When I format either of the CF cards to FAT32 format using my card reader on either by desktop pc, or my laptop, then copy the formatup.rok file to the card, the upgrade does not work. With the SanDisk card, it takes a long time (> 5 minutes) to boot but never does the upgrade. When it comes up it does not recognize that the card is installed. When I try the Viking card, the system never boots. If I boot without the card, then plug the card in, then telnet to the roku, it does not show anything mounted on /mnt/flash1. In either case, I take the card back to the card reader on my pc and I can verify that the file is there.

So, I tried formatting to FAT format. Now the system boots very quickly like normal, but no upgrade. It does recognize the card and displays the icon for it on the main screen. When I telnet into the roku, the card is mounted on /mnt/flash1 but the name of the file is fkriapup.rkk? The file size looks correct, but why is the name all goofed? Is it because roku doesn't read the FAT format? When I take it back to the card reader on the PC, the filename is fine. I get this behavior with both cards. I suspect that FAT format is not the right one, but why does roku recognize the card when it will not with FAT32, which I've read here is the correct one?

As mentioned, I've tried this on two different computers with different downloads of the upgrade file just to be sure I'm not getting a corrupted file. I know my card reader/writer works because after trying all of this I formatted it to FAT32, loaded a bunch of files on it, and used it without problem on my PDA.

I'm ready to start doing my imitation of a dog chewing hot pitch. Help?

Thanks,

-Jeff
 
timh
Posts: 39
Joined: Fri Sep 02, 2005 6:21 am

Sat Feb 25, 2006 12:33 pm

You might try this...

http://www.rokulabs.com/forums/viewtopic.php?t=1673&sid=b2d7dca8e524007193477ca742d4f4e9

Also, if it helps, my card is SanDisk UltraII 256 MB

Another idea, did you get the artpack on CF? You could backup the contents and try using it to do the upgrade. ???
Roku HD-1000 v2.0.36 (1080i),
Mitsu 65" HDTV (LCD RP),
S-A 8300HD STB/PVR,
XBOX,
Sony RDR-VX500 DVDR/VCR,
Onkyo TX-SR600 w/Polk Audio (5.1)
Logitech Harmony 676 Remote
 
jeffw
Topic Author
Posts: 14
Joined: Fri Feb 24, 2006 11:08 pm

Sat Feb 25, 2006 6:50 pm

You are the man. In all of my searching I had not found that thread. The on-line upgrade did the trick. Thank you very much for the help.

-Jeff

Who is online

Users browsing this forum: No registered users and 1 guest