Your Digital Media Has Never Looked So Good

 
User avatar
RokuDon
Roku Engineering
Topic Author
Posts: 199
Joined: Tue Aug 17, 2004 8:54 pm
Location: Palo Alto
Contact:

17-Jun: Beta 2.0.34 + SDK now available

Fri Jun 17, 2005 1:56 pm

Hi Folks,

We are pleased to announce our next beta software release, version 2.0.34.

THE MAIN FEATURE OF THIS RELEASE IS SUPPORT FOR PAL VIDEO MODES.

NOTE 1: The Cascade Platform was modified to support these PAL modes. As a result certain apps (such as MPlay) will need to be recompiled before they will work with this beta.

NOTE 2: If you do the network software upgrade, then your video mode will revert to Component 480i. You will need to manually change your video mode by going into Setup/Video Format. If you can't see anything on the screen (because for example you are using VGA), you can force-enter into video mode selection by pressing down Menu on the front panel and with it held down, pressing and releasing Exit on the front panel. When you then release Menu, the power light will start blinking and you will be in initial video format selection mode.

If you are running 2.0.28 or later, you may upgrade to this beta automatically on screen from "Setup/Software Update", otherwise you must use the traditional compact flash method of upgrading. (See http://www.rokulabs.com/forums/viewtopic.php?t=2904 for details).

You may use the traditional compact flash method of upgrading using the following URL:
http://www.rokulabs.com/developers/2.0.34/formatup.rok

The SDK may be downloaded from:
http://www.rokulabs.com/developers/Roku ... 2.0.34.zip
NOTE: Apps like MPlay that use CascadeScreen::GetSupportedOutputResolutionAt() *WILL* need to be modified and recompiled before they will work with 2.0.34.

As usual, it is recommended that you read this entire notice before upgrading to the new beta. Furthermore, it is recommended you also read the release notes of prior betas to familiarize yourself with their content as well.

As before, you may revert to previous software releases at any time. Links to download previous software releases are found in the release notes of prior betas located in this forum.

Following is a detailed description of this beta:

FEATURES
    The main feature of this release is support for PAL video modes.

    5 new video modes have been added:
    o PAL Component 720p 50Hz
    o PAL Component 1080i 50Hz
    o VGA 720p 50Hz
    o VGA 1080i 50Hz
    o VGA 1024x768 48Hz (custom mode to enable 24 fps filming of PhotoBridge output)

    The complete list of video modes (in setup order) is now:
    1: Component 480i
    2: S-Video 480i
    3: Composite 480i
    4: Component 480p
    5: Component 720p
    6: Component 1080i
    7: VGA 480p 60Hz
    8: VGA 720p 60Hz
    9: VGA 1080i 60Hz
    10: VGA 1024x768 60Hz
    11: VGA 1024x768 48Hz
    12: PAL Composite 576i 50Hz
    13: PAL S-Video 576i 50Hz
    14: PAL Component 720p 50Hz
    15: PAL Component 1080i 50Hz
    16: VGA 720p 50Hz
    17: VGA 1080i 50Hz
BUGS FIXED
    o sonata doesn't redraw properly after screensaver takedown
ENHANCEMENTS TO THE CASCADE PLATFORM
    o CascadeScreen::GetSupportedOutputResolutionAt() has changed to support 2 extra arguments: CascadeScreen::VideoMode (kNTSC, kPAL, kRGB) and u32 nRefreshRate (48, 50, or 60).

Enjoy,
The Roku Team
Last edited by RokuDon on Tue Oct 04, 2005 3:35 pm, edited 1 time in total.
 
marcelo3d
Posts: 382
Joined: Sat Oct 02, 2004 1:20 pm
Location: Santa Cruz, CA
Contact:

MPlay for 2.0.34 available

Fri Jun 17, 2005 2:54 pm

You can get it here:
http://home.pacbell.net/mar_ross/roku/M ... 2.0.34.zip

The only change is that was recompiled with the new SDK.

M.-
 
Toots Mutant
Posts: 195
Joined: Sun Aug 22, 2004 9:27 am

Fri Jun 17, 2005 4:25 pm

Wowie zowie batman!

You guys are great!
 
Steve Criz
Posts: 46
Joined: Wed Jan 12, 2005 1:34 am
Location: Katoomba

Fri Jun 17, 2005 7:44 pm

OK...

The following comments are regarding playback on a Aquos 83cm LCD HDTV (multi-format) with Photobridge (hardwire connected with 280Mb swap on 2Gig CF) set to test at 720p PAL 50Hz and 1080i PAL 50Hz modes with beta 2.0.34.

I've found that 1080i 50i HDV m2t clips from my FX-1e (PAL) begin to play back correctly, but after approx. 10-15 seconds they lose sound and display 'jerky' playback characterised by a 'wave' like rippling from the top to the bottom of screen.

DVD level 720x576 renders from the same HDV clips play wonderfully.

Perhaps the 23Mbit data rate is just too much for the Photobridge to cope with... but NTSC HDV files from a FX-1 (NTSC) at the exact same bit-rate play back smoothly and with synched sound.

I'll assume you don't have any FX-1e HDV PAL clips to test this on. As most of my clips are at least 150Meg, it may be difficult to send you one to try out...

Despite the HDV playback problem, it is most encouraging to see that PAL HD is now getting some attention, and DVD level PAL playback is operating perfectly.
 
Jowi
Posts: 100
Joined: Fri Oct 22, 2004 10:26 am
Location: Germany, Muelheim

Fri Jun 17, 2005 11:54 pm

Don,

great job. Thank you!!!!!!

My first impessions,

I have just updated and work with PAL S-Video 576i 50Hz. The picture ist great with no stuttering.

When i play back my DVD stuff with DD5.1 from HD i have no sound with the internal player sometimes. With MPLay, thanks to macelo3d for quick recompile, i have sound.

Thanks again.

Joachim
M740 AV 2.2.24b + Roku PhotoBridge + Zensonic Z500 -> Fritz!Box Fon WLAN 7050 -WDS- Fritz!Box Fon WLAN 7170 -> Buffalo LinkStation mit Twonkyvision 3.1.
 
SimonO
Posts: 394
Joined: Sat Sep 04, 2004 11:21 am
Location: UK
Contact:

Sat Jun 18, 2005 2:07 am

Jowi wrote:
...I have just updated and work with PAL S-Video 576i 50Hz. The picture ist great with no stuttering...

Thanks for the work on 50Hz Don, I'm also running S-Video 576i and the stuttering on PAL DVD is still there, Marcelo has told me that it's not an MPlay issue, any comments..?
Toshiba 36ZP48, Pace Sky+ v1 (120GB), Sonos ZP80, Denon DVD-2900, Denon AVR-3805, Blue Sky SAT 6.5/B&W DM600 S3/ASW675 w/Behringer DSP1124P, Philips Pronto NG RU950/RU951
 
soiaf
Posts: 785
Joined: Fri Jan 14, 2005 5:19 am

Sat Jun 18, 2005 6:35 am

Steve Criz wrote:
I'll assume you don't have any FX-1e HDV PAL clips to test this on. As most of my clips are at least 150Meg, it may be difficult to send you one to try out....


I suppose you could always burn a few clips to CD and mail the CD to Roku?
 
Jowi
Posts: 100
Joined: Fri Oct 22, 2004 10:26 am
Location: Germany, Muelheim

Sat Jun 18, 2005 7:43 am

Hi,

after playback many minutes of PAL stuff with the internal player i noticed some dropout. It looks like if there a black frame is added. If i stop the playback and run again the black frame is still there. After i reboot my PB the playback is ok. :?:

If i use MPlay to play the same file i rew 10 sec and the black frame is sometimes gone.

Greets

Joachim
M740 AV 2.2.24b + Roku PhotoBridge + Zensonic Z500 -> Fritz!Box Fon WLAN 7050 -WDS- Fritz!Box Fon WLAN 7170 -> Buffalo LinkStation mit Twonkyvision 3.1.
 
larryg99
Posts: 38
Joined: Tue Nov 02, 2004 10:23 am

Shuffle mode?

Sat Jun 18, 2005 9:36 am

Even though I was running 2.0.15, I was able to upgrade to 2.0.34 though the on-screen update. It seemd to install OK.

However, one thing I noticed is that my "Options" button in Sonata no longer functions, and I can't randomize music playback as a result. Is this feature currently disabled?
 
SimonO
Posts: 394
Joined: Sat Sep 04, 2004 11:21 am
Location: UK
Contact:

Re: Shuffle mode?

Sat Jun 18, 2005 10:24 am

larryg99 wrote:
...However, one thing I noticed is that my "Options" button in Sonata no longer functions, and I can't randomize music playback as a result. Is this feature currently disabled?...
Yes...
Toshiba 36ZP48, Pace Sky+ v1 (120GB), Sonos ZP80, Denon DVD-2900, Denon AVR-3805, Blue Sky SAT 6.5/B&W DM600 S3/ASW675 w/Behringer DSP1124P, Philips Pronto NG RU950/RU951
 
boba
Posts: 10
Joined: Fri Nov 12, 2004 3:00 pm

looping playlists

Sat Jun 18, 2005 3:12 pm

Hi,

Sometime during the last series of upgrades I noticed that my playlists now loop instead of running to the end and stopping.

Is this going to be fixed in a future release or, if this is a new "feature", will you offer an option to disable it? (Personally, I find it quite annoying).

Thanks in advance!!
 
roopeshsheth
Posts: 72
Joined: Tue May 31, 2005 2:58 pm
Location: San Diego

Sat Jun 18, 2005 7:38 pm

I've noticed that since .33 I've been unable to play videos from my MediaHome server reliably. They play for about 5 minutes then freeze up. Anyone else with this issue?
 
Gerald
Posts: 33
Joined: Sun Dec 26, 2004 5:46 am

Sun Jun 19, 2005 3:58 am

PAL!

Thank you thank you thank you.

Finally I can start using my Photobridge again - it's been sitting there ignored for months!
 
Gregavi
Posts: 102
Joined: Sun Dec 05, 2004 1:18 pm
Location: Santa Barbara, Ca.

Sun Jun 19, 2005 6:05 pm

I can't believe it. A new software release and still no shuffle, which is one of the most important features IMO, because we cannot access the "Options" menu. Very weak. What's the deal with shuffle, Roku? Was this an oversight or just a dumb decision not to re-implement it?
 
larryg99
Posts: 38
Joined: Tue Nov 02, 2004 10:23 am

Mon Jun 20, 2005 8:10 am

I agree! Hence, I have gone back to 2.0.15. There's no way I want to keep listening to my playlists in the same order.

Who is online

Users browsing this forum: No registered users and 3 guests