Your Digital Media Has Never Looked So Good

Topic Author
Posts: 4
Joined: Tue Feb 03, 2009 10:43 am

Connection issue ReadyNAS - SpeedTouch - Roku SoundBridge

Tue Feb 03, 2009 11:35 am

I have my ReadyNAS attached to the SpeedTouch router via wire. On the ReadyNAS I have Firefly Media Server running.
My Roku Soundbridge is attached to the SpeedTouch router wireless. When turning on the SoundBridge it is possible to listen to internet radio but it is unable to find the Firefly.
The SpeedTouch has multicast enabled.
After approximately 12 hours the SoundBridge finds the Firefly server and playback is possible on the SoundBridge.
If I do any changes to the Firefly or SpeedTouch configuration, I have to wait an additional 12 hours for the Fireflyto start working.
If I connect the SoundBridge via wire there are no problems connecting to the Firefly.

Anybody got an idea how to solve?

Thomson SpeedTouch 585v6 Firmware
Netgear ReadyNAS Duo Firmware 4.1.4 including Firefly svn1696
Pinnacle (Roku) SoundBridge M1001 Firmware 3.0.44

Posts: 623
Joined: Fri Dec 16, 2005 12:29 am
Location: Australia

Wed Feb 04, 2009 5:44 am

Same post in three places...
Check Firefly forum
2 x M2000's
Infrant ReadyNAS NV+ with Firefly svn-1676
NSLU2, 500GB Maxtor One Touch III, uNSLUng 6.8, Firefly svn-1696
music library in FLAC format
Topic Author
Posts: 4
Joined: Tue Feb 03, 2009 10:43 am

Issue solved

Sat Feb 07, 2009 3:21 pm

Downgraded my SpeedToch 585v6 firmware from to and everything now works flawless!! Both Roku and iTunes finds my ReadyNAS Firefly MediaServer without problem! Firmware found at speedtouchforum dot de.
Posts: 7
Joined: Sat Oct 04, 2008 5:23 am
Location: Tunisia

Sun Feb 08, 2009 1:51 am

Same router and same problem, as I've posted in another thread.
Roku in the WLAN cannot find Firefly, which is installed on my desktop (LAN).
Happy to ear that you solved the problem.
Actually the firmware of my router is the
How did you upgrade it?
I've had a look speedtouch forum, but I'm not too friendly with german language.
Many thanks
Topic Author
Posts: 4
Joined: Tue Feb 03, 2009 10:43 am

Sun Feb 08, 2009 2:03 am

First find the firmware ( at You'll find the firmwares at: SpeedTouch Firmware -> Firmware Archiv. You'll find the upgrade wizard in the version 5 firmare zip-files.
Then you'll need to downgrade (not upgrade) your Speedtouch. I found this desciptive instructions, which I encourage you to follow in detail or it won't work:

The easiest way to get the newer ST516/536/546/580/585 routers into bootp state is to do the following:

It is helpful though not essential to have the pc with a fixed static ip.

1. Begin with the unit powered off via the power switch at the back depressed.

2. Get a pin or a pen with a long enough nose to reach the reset button and hold it in.

3. Continue holding your pin or... on the reset button and do not release it. Power the unit on by pressing the power
button into the "on" state never releasing the reset.

4. Hold the reset button in for around 15 seconds. The power and Ethernet light should flash between red and green.

5. Run the SpeedTouch firmware upgrade wizard. You only have around 1min to start the wizard before the speedtouch will revert
to the normal boot up.

Note: It is always recommended to run the SpeedTouch firmware upgrade wizards with a statically set IP address on your PC of the

IP:, Subnet:, Default Gateway:

Note: It is best to have all security programmes (firewalls, antivirus) either disabled or turned completely off. (Edit from
Revs. It is absolutely essential not just best. The worst product is Symantec internet security because people don't know it is
on. Turn everything symantec off (permanently would be best!!).

Posts: 7
Joined: Sat Oct 04, 2008 5:23 am
Location: Tunisia

Sun Feb 08, 2009 3:11 am

Thanks for your prompt reply.
I've started the upgrade exe which is telling that the firmware enclosed in the ZZQIAA6.105.bin is not compatible. Should I believe on it?
Topic Author
Posts: 4
Joined: Tue Feb 03, 2009 10:43 am

Sun Feb 08, 2009 6:13 am

Ok, I would be a little careful here. If you flash your router with the wrong firmware it could end up useless. I can't decide for you, but I'm always very carful when flashing devices.

Who is online

Users browsing this forum: No registered users and 0 guests