Your Digital Media Has Never Looked So Good

 
Cgriell
Topic Author
Posts: 4
Joined: Wed Oct 01, 2014 3:32 am

Java, Opera, SoundBridge M1001

Sat Oct 04, 2014 4:25 am

Hi! I am an absolute newbie and I ran in quite a lot of troubles, and I was able to solve them with the help of this forum, so, let me make a summary of the problems I got to have my SoundBridge M1001 up and running and integrated.

Although I am a Mac User, it is easier to find help in the Windows world, so I used a brand new PC with Windows 8 (Beurkkkk), the last Java Update (V7.65), and Opera (V24.0). I connected the M1001 to my LAN through a cable (I use WPA2 security in my WiFi)

1.) Unable to find my device in Rokuradio. Before starting the search a window appear with the message that due to security reasons the program was blocked.

solution: go the the Java Security Window, and add http://rokuradio.com to the authorized sites (and do not forget to write http:// )

2.) Then it found my device but it was assigned to a different UniqueID. That's weird because I bought myself the set as new. Well, maybe someone had tested it before selling it to me. I wrote a question to Roku, as instructed, and get no answer. So, I perused this forum, and I found what must be done

solution: if you are under Windows 8 you must
a.) go to Control Panel>Programs>Windows features (or something similar) and check Telnet (it is deactivated by default). Then Restart windows
b.) locate the IP address of your device. If you have reached this point, I am sure that you now how to. Let me call it xxx.xxx.xxx.xxx
c.) go to command (yes, we are now on a MSDOS emulator) and write Telnet xxx.xxx.xxx.xxx 4444
you should get something like
Soundbridge >
write rcp
nothing (or maybe something, in my case roku ready) appears
write GetUniqueId (exactly spelled like this) and you will get something like a MAC number xx:xx:xx:xx:xx:xx (six groups of two hex numbers). This is not the MAC number !!! but by default the set Id is the same than the MAC)

then.. you must find a different Id. The Forum suggested to add one to the last group, I preferred to add 16 to the second, to avoid stepping on the garden of some other owner, so, I wrote a 1 on the first number of the second group. This was a bad idea, it did not work, so, I added one. My identifier went from 00:0D:4B:05:16 to 00:0D:4B:05:17 so...

write SetUniqueId 00:0D:4B:05:17
it answers OK
write exit
it writes SoundBridge>
you write reboot.

and you are done.

You go back to Rokuradio.com you search for your device and you will find it

I was not yet done, because the widget My SoundBridge appeared, but with a message : Not detected on local Network

Messages in the Forum said that this was due to the last Java Upgrade (back in 2013) and it was an incompatibity between the new Java and the obsolete SoundBridge software, and there was nothing to be done.

well this is not true, because with Explorer (eccssss) (V11) it works, my SoundBridge appeared as connected

Of course to configure this took some hours (probably 4 or 5), but quite a lot of minutes were spent searching how to do things, more than actually doing them

Who is online

Users browsing this forum: No registered users and 0 guests